import Foundation
let pattern = #"^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"FA12-BSE-008"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}