using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*?\/storage\/([^?]*).*?>";
string substitution = @"<img src=""http://mydomainname.com/wp-content/uploads/$1"">";
string input = @"Random text <img style=""width: 250px;"" src=""/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524"" alt="" align=""left"" hspace=""5"" vspace=""5""> more text";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}