import Foundation
let pattern = #"<img.*?\/storage\/([^?]*).*?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Random text <img style="width: 250px;" src="/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524" alt="" align="left" hspace="5" vspace="5"> more text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="http://mydomainname.com/wp-content/uploads/$1">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)