# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.*?\/storage\/([^?]*).*?>"
test_str = "Random text <img style=\"width: 250px;\" src=\"/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524\" alt=\"\" align=\"left\" hspace=\"5\" vspace=\"5\"> more text"
subst = "<img src=\"http://mydomainname.com/wp-content/uploads/$1\">"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.