package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img.*?\/storage\/([^?]*).*?>`)
var str = `Random text <img style="width: 250px;" src="/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524" alt="" align="left" hspace="5" vspace="5"> more text`
var substitution = "<img src="http://mydomainname.com/wp-content/uploads/$1">"
fmt.Println(re.ReplaceAllString(str, substitution))
}