use strict;
my $str = 'Random text <img style="width: 250px;" src="/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524" alt="" align="left" hspace="5" vspace="5"> more text';
my $regex = qr/<img.*?\/storage\/([^?]*).*?>/ip;
my $subst = '<img src="http://mydomainname.com/wp-content/uploads/$1">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";