$re = '/<img.*?\/storage\/([^?]*).*?>/i';
$str = 'Random text <img style="width: 250px;" src="/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524" alt="" align="left" hspace="5" vspace="5"> more text';
$subst = "<img src=\"http://mydomainname.com/wp-content/uploads/$1\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;