import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?\\/storage\\/([^?]*).*?>";
final String string = "Random text <img style=\"width: 250px;\" src=\"/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524\" alt=\"\" align=\"left\" hspace=\"5\" vspace=\"5\"> more text";
final String subst = "<img src=\"http://mydomainname.com/wp-content/uploads/$1\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}