const regex = /<img.*?\/storage\/([^?]*).*?>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?\\\/storage\\\/([^?]*).*?>', 'ig')
const str = `Random text <img style="width: 250px;" src="/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524" alt="" align="left" hspace="5" vspace="5"> more text`;
const subst = `<img src="http://mydomainname.com/wp-content/uploads/$1">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);