// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<img.*?\/storage\/([^?]*).*?>").unwrap();
let string = "Random text <img style=\"width: 250px;\" src=\"/storage/IMG_3843.JPG?__SQUARESPACE_CACHEVERSION=1413512531524\" alt=\"\" align=\"left\" hspace=\"5\" vspace=\"5\"> more text";
let substitution = "<img src=\"http://mydomainname.com/wp-content/uploads/$1\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}