# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб/$1$2&&/g;t' <<< "Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)"