use strict;
my $str = 'Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)';
my $regex = qr/руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб/p;
my $subst = '$1$2&&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";