#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб"
Local $sString = "Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)"
Local $sSubst = "$1$2&&"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)