// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб").unwrap();
let string = "Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)";
let substitution = "$1$2&&";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}