const regex = /руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('руб\\.\\ ?(\\d[\\d.]+)|(\\d[\\d.]*)\\ ?руб', 'g')
const str = `Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)`;
const subst = `$1$2&&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);