import Foundation
let pattern = #"руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2&&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)