using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб";
string substitution = @"$1$2&&";
string input = @"Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}