package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб`)
var str = `Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)`
var substitution = "$1$2&&"
fmt.Println(re.ReplaceAllString(str, substitution))
}