re = /руб\.\ ?(\d[\d.]+)|(\d[\d.]*)\ ?руб/
str = 'Right (99.99руб.) OR Left with space (руб. 99.99) OR Right with space (99.99 руб.) OR Left (руб.99.99)'
subst = '$1$2&&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result