using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\index\{(\w+(?:\s+\w+){0,4})\})";
string substitution = @"\1\\textbf{\2}";
string input = @"blah blah \index{words}words ramble on
more blah more blah\index{space words} space words ramble on
final blah\textbf{bold words} ramble on
final blah\index{word1 word2 word3 word4 word5 word6} ramble on";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}