import Foundation
let pattern = #"(\\index\{(\w+(?:\s+\w+){0,4})\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
blah blah \index{words}words ramble on
more blah more blah\index{space words} space words ramble on
final blah\textbf{bold words} ramble on
final blah\index{word1 word2 word3 word4 word5 word6} ramble on
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\textbf{\2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)