// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\\index\{(\w+(?:\s+\w+){0,4})\})").unwrap();
let string = "blah blah \\index{words}words ramble on
more blah more blah\\index{space words} space words ramble on
final blah\\textbf{bold words} ramble on
final blah\\index{word1 word2 word3 word4 word5 word6} ramble on";
let substitution = "\\1\\\\textbf{\\2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}