# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\\index\{(\w+(?:\s+\w+){0,4})\})"
test_str = ("blah blah \\index{words}words ramble on\n"
"more blah more blah\\index{space words} space words ramble on\n"
"final blah\\textbf{bold words} ramble on\n"
"final blah\\index{word1 word2 word3 word4 word5 word6} ramble on")
subst = "\\1\\\\textbf{\\2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.