$re = '/(\\\\index\{(\w+(?:\s+\w+){0,4})\})/';
$str = 'blah blah \\index{words}words ramble on
more blah more blah\\index{space words} space words ramble on
final blah\\textbf{bold words} ramble on
final blah\\index{word1 word2 word3 word4 word5 word6} ramble on';
$subst = "\1\\textbf{\2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;