package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\\index\{(\w+(?:\s+\w+){0,4})\})`)
var str = `blah blah \index{words}words ramble on
more blah more blah\index{space words} space words ramble on
final blah\textbf{bold words} ramble on
final blah\index{word1 word2 word3 word4 word5 word6} ramble on`
var substitution = "\1\\textbf{\2}"
fmt.Println(re.ReplaceAllString(str, substitution))
}