const regex = /(\\index\{(\w+(?:\s+\w+){0,4})\})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\index\\{(\\w+(?:\\s+\\w+){0,4})\\})', 'g')
const str = `blah blah \\index{words}words ramble on
more blah more blah\\index{space words} space words ramble on
final blah\\textbf{bold words} ramble on
final blah\\index{word1 word2 word3 word4 word5 word6} ramble on`;
const subst = `\1\\textbf{\2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);