import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\index\\{(\\w+(?:\\s+\\w+){0,4})\\})";
final String string = "blah blah \\index{words}words ramble on\n"
+ "more blah more blah\\index{space words} space words ramble on\n"
+ "final blah\\textbf{bold words} ramble on\n"
+ "final blah\\index{word1 word2 word3 word4 word5 word6} ramble on";
final String subst = "\\1\\\\textbf{\\2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}