use strict;
my $str = 'blah blah \\index{words}words ramble on
more blah more blah\\index{space words} space words ramble on
final blah\\textbf{bold words} ramble on
final blah\\index{word1 word2 word3 word4 word5 word6} ramble on';
my $regex = qr/(\\index\{(\w+(?:\s+\w+){0,4})\})/p;
my $subst = '\\1\\\\textbf{\\2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";