# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)//gm;t' <<< "Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]"