package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)`)
var str = `Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}