use strict;
my $str = 'Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]';
my $regex = qr/(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";