#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)"
Local $sString = "Title: (some text)" & @CRLF & _
"My Title [abc]" & @CRLF & _
"" & @CRLF & _
"Content: (some test)" & @CRLF & _
"My long content paragraph. With multiple sentences. [abc]" & @CRLF & _
"" & @CRLF & _
"Short Content: (some text)" & @CRLF & _
"Short content [abc]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)