re = /(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)/m
str = 'Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result