$re = '/(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)/m';
$str = 'Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;