# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)"
test_str = ("Title: (some text)\n"
"My Title [abc]\n\n"
"Content: (some test)\n"
"My long content paragraph. With multiple sentences. [abc]\n\n"
"Short Content: (some text)\n"
"Short content [abc]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.