const regex = /(\(some text\)\n|\(some test\)\n|(\[abc\]))|(^$\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(some text\\)\\n|\\(some test\\)\\n|(\\[abc\\]))|(^$\\n)', 'gm')
const str = `Title: (some text)
My Title [abc]
Content: (some test)
My long content paragraph. With multiple sentences. [abc]
Short Content: (some text)
Short content [abc]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);