import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(some text\\)\\n|\\(some test\\)\\n|(\\[abc\\]))|(^$\\n)";
final String string = "Title: (some text)\n"
+ "My Title [abc]\n\n"
+ "Content: (some test)\n"
+ "My long content paragraph. With multiple sentences. [abc]\n\n"
+ "Short Content: (some text)\n"
+ "Short content [abc]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}