# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?:\&\&|\|\|)(?!\S)/<<\g<0>>>/gm;t' <<< "good && toast&&guest &fast& slow||wind ||old|| new || very good"