#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)(?:\&\&|\|\|)(?!\S)"
Local $sString = "good && toast&&guest &fast& slow||wind ||old|| new || very good"
Local $sSubst = "<<\g<0>>>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)