$re = '/(?<!\S)(?:\&\&|\|\|)(?!\S)/m';
$str = 'good && toast&&guest &fast& slow||wind ||old|| new || very good';
$subst = "<<\g<0>>>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;