import Foundation
let pattern = #"(?<!\S)(?:\&\&|\|\|)(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"good && toast&&guest &fast& slow||wind ||old|| new || very good"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<<\g<0>>>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)