import re
regex = re.compile(r"(?<!\S)(?:\&\&|\|\|)(?!\S)", flags=re.MULTILINE)
test_str = "good && toast&&guest &fast& slow||wind ||old|| new || very good"
subst = "<<\\g<0>>>"
result = regex.sub(subst, test_str)
if result:
print(result)