re = /(?<!\S)(?:\&\&|\|\|)(?!\S)/m
str = 'good && toast&&guest &fast& slow||wind ||old|| new || very good'
subst = '<<\\g<0>>>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result