const regex = new RegExp('(?<!\\S)(?:\\&\\&|\\|\\|)(?!\\S)', 'gm')
const str = `good && toast&&guest &fast& slow||wind ||old|| new || very good`;
const subst = `<<\g<0>>>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);