using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:\&\&|\|\|)(?!\S)";
string substitution = @"<<\g<0>>>";
string input = @"good && toast&&guest &fast& slow||wind ||old|| new || very good";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}