# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a href=".*?"/<a href="#"/gm;t' <<< "<td>
[<a href=\"/abc123/handouts/files/directory1/somename.pdf\" target=\"_blank\">Slides</a> ] [ [<a href=\"/abc123/handouts/files/directory2/somename2.pdf\" target=\"_blank\">Handout</a> ]</td>
<td>
[<a href=\"/abc123/handouts/files/directory3/somename343.pdf\" target=\"_blank\">Slides</a> ] [ <a href=\"/abc123/handouts/files/directory5/somename2324.pdf\" target=\"_blank\">Handout</a> ]
</td>"