using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href="".*?""";
string substitution = @"<a href=""#""";
string input = @"<td>
[<a href=""/abc123/handouts/files/directory1/somename.pdf"" target=""_blank"">Slides</a> ] [ [<a href=""/abc123/handouts/files/directory2/somename2.pdf"" target=""_blank"">Handout</a> ]</td>
<td>
[<a href=""/abc123/handouts/files/directory3/somename343.pdf"" target=""_blank"">Slides</a> ] [ <a href=""/abc123/handouts/files/directory5/somename2324.pdf"" target=""_blank"">Handout</a> ]
</td>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}