import Foundation
let pattern = #"<a href=".*?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<td>
[<a href="/abc123/handouts/files/directory1/somename.pdf" target="_blank">Slides</a> ] [ [<a href="/abc123/handouts/files/directory2/somename2.pdf" target="_blank">Handout</a> ]</td>
<td>
[<a href="/abc123/handouts/files/directory3/somename343.pdf" target="_blank">Slides</a> ] [ <a href="/abc123/handouts/files/directory5/somename2324.pdf" target="_blank">Handout</a> ]
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<a href="#""##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)