use strict;
my $str = '<td>
[<a href="/abc123/handouts/files/directory1/somename.pdf" target="_blank">Slides</a> ] [ [<a href="/abc123/handouts/files/directory2/somename2.pdf" target="_blank">Handout</a> ]</td>
<td>
[<a href="/abc123/handouts/files/directory3/somename343.pdf" target="_blank">Slides</a> ] [ <a href="/abc123/handouts/files/directory5/somename2324.pdf" target="_blank">Handout</a> ]
</td>';
my $regex = qr/<a href=".*?"/mp;
my $subst = '<a href="#"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";