import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\".*?\"";
final String string = "<td>\n"
+ "[<a href=\"/abc123/handouts/files/directory1/somename.pdf\" target=\"_blank\">Slides</a> ] [ [<a href=\"/abc123/handouts/files/directory2/somename2.pdf\" target=\"_blank\">Handout</a> ]</td>\n\n"
+ "<td>\n"
+ "[<a href=\"/abc123/handouts/files/directory3/somename343.pdf\" target=\"_blank\">Slides</a> ] [ <a href=\"/abc123/handouts/files/directory5/somename2324.pdf\" target=\"_blank\">Handout</a> ]\n"
+ "</td>";
final String subst = "<a href=\"#\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}